aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-21 19:47:22 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-21 19:47:22 +0000
commita72640365067d3a116f7d02baefd0d37d0c68e6f (patch)
treebff2daf83bc40038b2c26343bbdc1a94f5cd1bd3 /target/linux/ar71xx/image/Makefile
parent0f8539915a8b395ba2c991722d2832014f85b833 (diff)
downloadmaster-187ad058-a72640365067d3a116f7d02baefd0d37d0c68e6f.tar.gz
master-187ad058-a72640365067d3a116f7d02baefd0d37d0c68e6f.tar.bz2
master-187ad058-a72640365067d3a116f7d02baefd0d37d0c68e6f.zip
ar71xx: build TP-LINK Archer C7 images with US region code
Since December 2015, the Archer C7 comes with an US-specific firmware. This firmware will only allow upgrades with images that contain the US region code in the firmware header. The "universal" firmware distributed in the rest of the world doesn't care about the region code, so we can just unconditionally set the region to US for now. When other region-specific firmwares appear, we'll need to create a factory image for each of them. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49217 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 2699b64878..2b2e868822 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -414,6 +414,7 @@ define Device/archer-c7-v2
BOARDNAME := ARCHER-C7
DEVICE_PROFILE := ARCHERC7
TPLINK_HWID := 0xc7000002
+ IMAGE/factory.bin := append-rootfs | mktplinkfw factory -C US
endef
define Device/tl-wdr7500-v3