aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:09 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:09 +0000
commit780aecc9ca1d16c15695d001606ad4352b4c455e (patch)
treed71c5c4cc477c2a3dd0e3e16e4b161aeaa83e406 /target/linux/ar71xx/image/Makefile
parent0e45b3367c633bec0f1b67d2a50ec0c23999f7e5 (diff)
downloadmaster-187ad058-780aecc9ca1d16c15695d001606ad4352b4c455e.tar.gz
master-187ad058-780aecc9ca1d16c15695d001606ad4352b4c455e.tar.bz2
master-187ad058-780aecc9ca1d16c15695d001606ad4352b4c455e.zip
ar71xx: support for D-LINK DIR-615 rev. E4
This patch adds support for D-LINK DIR-615 E4 board. It's mostly based on the existing support for DIR-600 A1, with some changes in the leds configuration. It's an updated version of the patch that reliably works on my hw for about a year (it was built from trunk on Jan 2011). When I decided to update the firmware and checked for the current support for that device, I also found previously posted patches by Alexey Loukianov that mentioned some stability issues. I'm not sure where could be the difference, the patches are very similar except the wmac led pin number - I was using 1, and those patches used 17. [juhosg: add 3.2 support] Signed-off-by: Vadim Girlin <vadimgirlin@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29973 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index bd5e945f59..19e26ad2d6 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -698,6 +698,11 @@ define Image/Build/Profile/DIR600A1
$(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-600-a1,$(dir600a1_cmdline),"AP91-AR7240-RT-090223-00")
endef
+dir615e4_cmdline=board=DIR-615-E4 console=ttyS0,115200
+define Image/Build/Profile/DIR615E4
+ $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-615-e4,$(dir615e4_cmdline),"AP99-AR7240-RT-091105-05")
+endef
+
eap7660d_cmdline=board=EAP7660D console=ttyS0,115200
define Image/Build/Profile/EAP7660D
$(call Image/Build/Template/$(fs_128k)/$(1),PB4X,eap7660d,$(eap7660d_cmdline))
@@ -995,6 +1000,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/DB120,$(1))
$(call Image/Build/Profile/DIR600A1,$(1))
$(call Image/Build/Profile/DIR615C1,$(1))
+ $(call Image/Build/Profile/DIR615E4,$(1))
$(call Image/Build/Profile/DIR825B1,$(1))
$(call Image/Build/Profile/EAP7660D,$(1))
$(call Image/Build/Profile/FR54RTR,$(1))