aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:24:04 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:24:04 +0000
commit44ecb4d35d1e487fa9049642617034d676c1bf25 (patch)
treea2932f8593ee673a98d6a5596d3d98e3cb41989b /target/linux/ar71xx/image/Makefile
parent1c34671957be15a92a4e6797b502002b9898dc62 (diff)
downloadmaster-187ad058-44ecb4d35d1e487fa9049642617034d676c1bf25.tar.gz
master-187ad058-44ecb4d35d1e487fa9049642617034d676c1bf25.tar.bz2
master-187ad058-44ecb4d35d1e487fa9049642617034d676c1bf25.zip
ar71xx: add support for TP-Link TL-WDR6500 v2
Signed-off-by: Weijie Gao <hackpascal@gmail.com> This patch adds support for TP-Link TL-WDR6500 v2. The firmware has a U-Boot header for kernel, and a TP-LINK v2 header for the whole firmware, so I have to create a new firmware creation method. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46663 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3508913dfc..8f609de774 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1745,6 +1745,37 @@ define Image/Build/TPLINK-LZMA/initramfs
-o $(call imgname,$(1),$(2))-uImage.bin
endef
+Image/Build/TPLINK-64K/buildkernel=$(call PatchKernelLzma,$(2),$(3))
+
+define Image/Build/TPLINK-64K
+ -$(STAGING_DIR_HOST)/bin/mkimage \
+ -A mips -O linux -T kernel -a 0x80060000 -C lzma \
+ -e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $$(KDIR_TMP)/vmlinux-$(2).bin.lzma $(KDIR_TMP)/vmlinux-$(2).bin.lzma.img
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -H $(4) -W $(5) -F $(6) -N OpenWrt -m 2 -V $(REVISION) $(7) \
+ -X 0x20000 \
+ -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma.img \
+ -r $(KDIR)/root.$(1) \
+ -a $(call rootfs_align,$(1)) -j \
+ -o $(call factoryname,$(1),$(2))
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -H $(4) -W $(5) -F $(6) -N OpenWrt -m 2 -V $(REVISION) $(7) -s \
+ -X 0x20000 \
+ -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma.img \
+ -r $(KDIR)/root.$(1) \
+ -a $(call rootfs_align,$(1)) -j \
+ -o $(call sysupname,$(1),$(2))
+endef
+
+define Image/Build/TPLINK-64K/initramfs
+ $(call PatchKernelLzma,$(2),$(3),,-initramfs)
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
+ -H $(4) -W $(5) -F $(6) -N OpenWrt -m 2 -V $(REVISION) $(7) -s \
+ -k $(KDIR_TMP)/vmlinux-initramfs-$(2).bin.lzma.img \
+ -o $(call imgname,$(1),$(2))-uImage.bin
+endef
+
Image/Build/TPLINK-SAFELOADER/loader = $(call Image/BuildLoaderPatched,$(1),elf,$(2) $(3))
@@ -2173,6 +2204,8 @@ $(eval $(call SingleProfile,TPLINK,64kraw,TLWR1043V1,tl-wr1043nd-v1,TL-WR1043ND,
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR1043V2,tl-wr1043nd-v2,TL-WR1043ND-v2,ttyS0,115200,0x10430002,1,8M))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR2543,tl-wr2543-v1,TL-WR2543N,ttyS0,115200,0x25430001,1,8Mlzma,-v 3.13.99))
+$(eval $(call SingleProfile,TPLINK-64K,64kraw,TLWDR6500V2,tl-wdr6500-v2,TL-WDR6500-v2,ttyS0,115200,0x65000002,1,8Mlzma))
+
$(eval $(call SingleProfile,TPLINK-SAFELOADER,64kraw,CPE510,cpe210-220-510-520,CPE510,ttyS0,115200,$$(cpe510_mtdlayout),CPE510))
$(eval $(call SingleProfile,WHRHPG300N,64kraw,WHRG301N,whr-g301n,WHR-G301N,ttyS0,115200,$$(whrhpg300n_mtdlayout),WHR-G301N))