aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-31 09:29:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-31 09:29:48 +0000
commit2c475f490dcb1a2cedd4e4cc6dc3289762158fd1 (patch)
tree630550e5107fe8c9c4406531edae246f38bcd333 /target/linux/ar71xx/image/Makefile
parent52e2c0043d11c9a38ec80a76e11a55715bbc7bf2 (diff)
downloadmaster-187ad058-2c475f490dcb1a2cedd4e4cc6dc3289762158fd1.tar.gz
master-187ad058-2c475f490dcb1a2cedd4e4cc6dc3289762158fd1.tar.bz2
master-187ad058-2c475f490dcb1a2cedd4e4cc6dc3289762158fd1.zip
ar71xx/image: remove old unused build code for TPLINK
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47321 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile33
1 files changed, 0 insertions, 33 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 141a2d7133..d2165d95d7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1891,39 +1891,6 @@ define Image/Build/Senao
$(call sysupname,$(1),$(2))
endef
-Image/Build/TPLINK/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
-
-define Image/Build/TPLINK
- [ -e "$(KDIR)/loader-$(2).gz" ]
- $(call MkuImageOKLI,$(2))
- ( \
- dd if=$(KDIR)/loader-$(2).gz bs=7680 count=1 conv=sync; \
- dd if=$(KDIR_TMP)/vmlinux-$(2).okli conv=sync; \
- ) > $(KDIR_TMP)/kernel-$(2).bin
- -$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION)\
- -X 0x40000 \
- -k $(KDIR_TMP)/kernel-$(2).bin \
- -r $(KDIR)/root.$(1) \
- -a $(call rootfs_align,$(1)) -j \
- -o $(call factoryname,$(1),$(2))
- -$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s\
- -X 0x40000 \
- -k $(KDIR_TMP)/kernel-$(2).bin \
- -r $(KDIR)/root.$(1) \
- -a $(call rootfs_align,$(1)) -j \
- -o $(call sysupname,$(1),$(2))
-endef
-
-define Image/Build/TPLINK/initramfs
- $(call Image/BuildLoader,$(2),gz,$(3),0x80060000,-initramfs)
- -$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
- -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s\
- -k $(KDIR)/loader-$(2)-initramfs.gz \
- -o $(call imgname,$(1),$(2))-uImage.bin
-endef
-
Image/Build/TPLINK-SAFELOADER/loader = $(call Image/BuildLoaderPatched,$(1),elf,$(2) $(3))
define Image/Build/TPLINK-SAFELOADER