aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 17:55:25 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 17:55:25 +0000
commitdfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3 (patch)
tree12e48ac4df23edfd912270c88c4765cff5e30969 /target/linux/ar71xx/generic
parent1730dcd62fdeb38149daee4abce497b5be201435 (diff)
downloadmaster-187ad058-dfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3.tar.gz
master-187ad058-dfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3.tar.bz2
master-187ad058-dfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to trunk
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox into trunk (or 'Designated Driver' :D ). Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners on 15.05. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47234 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk b/target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk
new file mode 100644
index 0000000000..1484114230
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/gs-minibox-v1.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MINIBOXV1
+ NAME:=Gainstrong MiniBox V1.0
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+
+define Profile/MINIBOXV1/Description
+ Package set optimized for the Gainstrong MiniBox V1.0
+endef
+$(eval $(call Profile,MINIBOXV1))