aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-26 08:59:32 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-26 08:59:32 +0000
commitce4e6eb2e1aa82031d4369e7a40eacaca4691c6d (patch)
tree8c8c669b0e34f53474996c568a088c18c8bbfbd4 /target/linux/ar71xx/generic
parentfe9456a922cc566c0349dee96808ab5e4f8263be (diff)
downloadmaster-187ad058-ce4e6eb2e1aa82031d4369e7a40eacaca4691c6d.tar.gz
master-187ad058-ce4e6eb2e1aa82031d4369e7a40eacaca4691c6d.tar.bz2
master-187ad058-ce4e6eb2e1aa82031d4369e7a40eacaca4691c6d.zip
ar71xx: add support for TP-LINK CPE210/220/510/520
This adds support for the TP-LINK CPE210/220/510/520 (Pharos series). These devices are very similar to the Ubiquiti NanoStations, but with better specs: faster CPU, more RAM, 2x2 MIMO. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43385 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 78333be0b5..a9d170c754 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -16,6 +16,17 @@ endef
$(eval $(call Profile,ARCHERC7))
+define Profile/CPE510
+ NAME:=TP-LINK CPE210/220/510/520
+ PACKAGES:=rssileds
+endef
+
+define Profile/CPE510/Description
+ Package set optimized for the TP-LINK CPE210/220/510/520.
+endef
+$(eval $(call Profile,CPE510))
+
+
define Profile/TLMR10U
NAME:=TP-LINK TL-MR10U
PACKAGES:=kmod-usb-core kmod-usb2