aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-05-23 15:27:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-05-23 15:27:22 +0000
commitc039a6cb03c383a4c9ef43f0d9e034a5830feb95 (patch)
tree0956d41a394242cc812f779f1418f802ce79f0ef /target/linux/ar71xx/generic
parent293fafe0c5adfd7ffb67048f1b7507ee7e3738d6 (diff)
downloadmaster-187ad058-c039a6cb03c383a4c9ef43f0d9e034a5830feb95.tar.gz
master-187ad058-c039a6cb03c383a4c9ef43f0d9e034a5830feb95.tar.bz2
master-187ad058-c039a6cb03c383a4c9ef43f0d9e034a5830feb95.zip
ar71xx: Add support for the Meraki MR12 & MR16
This patch is to add support for the Meraki MR12 and MR16 Access Points. Currently everything is working, minus the 2nd NIC interface on the MR12 which is built into the SoC. Signed-off-by: Chris R Blake <chrisrblake93 at gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45726 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/meraki.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/meraki.mk b/target/linux/ar71xx/generic/profiles/meraki.mk
new file mode 100644
index 0000000000..0d5cda0fd2
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/meraki.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2014-2015 Chris Blake (chrisrblake93@gmail.com)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MR12
+ NAME:=Meraki MR12
+ PACKAGES:=kmod-spi-gpio kmod-ath9k
+endef
+
+define Profile/MR12/description
+ Package set optimized for the Cisco Meraki MR12 Access Point.
+endef
+
+define Profile/MR16
+ NAME:=Meraki MR16
+ PACKAGES:=kmod-spi-gpio kmod-ath9k
+endef
+
+define Profile/MR16/description
+ Package set optimized for the Cisco Meraki MR16 Access Point.
+endef
+
+$(eval $(call Profile,MR12))
+$(eval $(call Profile,MR16)) \ No newline at end of file