aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-13 07:29:10 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-13 07:29:10 +0000
commit81ec62aa17a2aeba2e69c842f8416df5db2ec1ac (patch)
tree01980b73c3dc6fc3229576235b6568a5ab760a51 /target/linux/ar71xx/generic
parent5f00ace3c25e4988e94ebfc2b12b3e978bf7d4eb (diff)
downloadmaster-187ad058-81ec62aa17a2aeba2e69c842f8416df5db2ec1ac.tar.gz
master-187ad058-81ec62aa17a2aeba2e69c842f8416df5db2ec1ac.tar.bz2
master-187ad058-81ec62aa17a2aeba2e69c842f8416df5db2ec1ac.zip
ar71xx: Add profile and build image for TP-Link MR12U v1
This patch adds corrected profile and build image for the TL-MR12U board. Unfortunately i cannot test the factory image since i can't find anywhere the original chinese firmware but the generated openwrt-ar71xx-generic-tl-mr12u-v1-squashfs-sysupgrade.bin worked just fine over a modified mr3040 factory image i managed to modify to initially flash the mr12u from the original firmware. Proper kernel support probably should be added since cat /proc/cpuinfo shows MR13U. Signed-off-by: Daniel Petre <daniel.petre@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44427 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index c7a65e4af2..5922f67399 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -48,6 +48,16 @@ define Profile/TLMR11U/Description
endef
$(eval $(call Profile,TLMR11U))
+define Profile/TLMR12U
+ NAME:=TP-LINK TL-MR12U
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR12U/Description
+ Package set optimized for the TP-LINK TL-MR12U.
+endef
+
+$(eval $(call Profile,TLMR12U))
define Profile/TLMR13U
NAME:=TP-LINK TL-MR13U