aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 09:17:09 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 09:17:09 +0000
commit77a10161ae168fcf451140e2d72e86c1c4275034 (patch)
tree48191bd848689ee60d35af346e4993c9cd43794a /target/linux/ar71xx/generic
parent1c9268405ea006c8ac01c6cfef1774070ebafada (diff)
downloadmaster-187ad058-77a10161ae168fcf451140e2d72e86c1c4275034.tar.gz
master-187ad058-77a10161ae168fcf451140e2d72e86c1c4275034.tar.bz2
master-187ad058-77a10161ae168fcf451140e2d72e86c1c4275034.zip
ar71xx: Add OOLITE to the Gainstrong profile, removed standalone profile.
This patch moves the OOLITE profile code into the overarching Gainstrong profile and deletes the old single profile file. Signed-off by: Stijn Segers <francesco.borromini@inventati.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/gainstrong.mk11
-rw-r--r--target/linux/ar71xx/generic/profiles/oolite.mk18
2 files changed, 11 insertions, 18 deletions
diff --git a/target/linux/ar71xx/generic/profiles/gainstrong.mk b/target/linux/ar71xx/generic/profiles/gainstrong.mk
index a82529ddf1..8f7a48506e 100644
--- a/target/linux/ar71xx/generic/profiles/gainstrong.mk
+++ b/target/linux/ar71xx/generic/profiles/gainstrong.mk
@@ -15,3 +15,14 @@ define Profile/MINIBOXV1/Description
Package set optimized for the Gainstrong MiniBox V1.0
endef
$(eval $(call Profile,MINIBOXV1))
+
+define Profile/OOLITE
+ NAME:=Gainstrong OOLITE
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+
+define Profile/OOLITE/Description
+ Package set optimized for the Gainstrong OOLITE.
+endef
+$(eval $(call Profile,OOLITE))
diff --git a/target/linux/ar71xx/generic/profiles/oolite.mk b/target/linux/ar71xx/generic/profiles/oolite.mk
deleted file mode 100644
index 448f08d693..0000000000
--- a/target/linux/ar71xx/generic/profiles/oolite.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/OOLITE
- NAME:=OOLITE
- PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
-endef
-
-
-define Profile/OOLITE/Description
- Package set optimized for the OOLITE.
-endef
-$(eval $(call Profile,OOLITE))
-