aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:05 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:05 +0000
commit6f137449e8ac99312a1d097b8208530fe2136923 (patch)
treee8da496bac55c7a678d1ebd5ded5d3f757205fa6 /target/linux/ar71xx/generic
parent3146134687cbd0a49243d623063b1563013c12a7 (diff)
downloadmaster-187ad058-6f137449e8ac99312a1d097b8208530fe2136923.tar.gz
master-187ad058-6f137449e8ac99312a1d097b8208530fe2136923.tar.bz2
master-187ad058-6f137449e8ac99312a1d097b8208530fe2136923.zip
ar71xx: Add Support for the Bitmain Antminer S1
This patch adds support for the Bitmain Antminer S1 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s1 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: James Hilliard <james.hilliard1@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46044 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/antminer.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/antminer.mk b/target/linux/ar71xx/generic/profiles/antminer.mk
new file mode 100644
index 0000000000..366982c885
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/antminer.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ANTMINER_S1
+ NAME:=Antminer S1
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINER_S1/Description
+ Package set optimized for the Bitmain Antminer S1.
+endef
+$(eval $(call Profile,ANTMINER_S1))