aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:35 +0000
commit6db53dd444c820146d176ce4e0310a0333ed0831 (patch)
tree6fee5e8360288120acd69471cc4cc766f3865028 /target/linux/ar71xx/generic
parent372bf44dad630811fa8de131014b2b96d6c505c3 (diff)
downloadmaster-187ad058-6db53dd444c820146d176ce4e0310a0333ed0831.tar.gz
master-187ad058-6db53dd444c820146d176ce4e0310a0333ed0831.tar.bz2
master-187ad058-6db53dd444c820146d176ce4e0310a0333ed0831.zip
target: ar71xx: add support for COMFAST CF-E316N v2 board
This adds full support (sans sysupgrading from vendor firmware) for the COMFAST CF-E316N v2 (aka CF-E316V2, CF-E316N-V2 and CF-E316Nv2.0, no FCC ID) by Shenzhen Four Seas Global Link Network Technology Co., Ltd (this company is actively refusing to provide GPL'd sources for the OpenWrt version they ship with the device, damn them). Signed-off-by: Paul Fertser <fercerpav@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46852 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/comfast.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/comfast.mk b/target/linux/ar71xx/generic/profiles/comfast.mk
new file mode 100644
index 0000000000..5d447e5cec
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/comfast.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/CF-E316N-V2
+ NAME:=COMFAST CF-E316N v2
+ PACKAGES:=
+endef
+
+define Profile/CF-E316N-V2/Description
+ Package set optimised for the COMFAST CF-E316N v2
+ by Shenzhen Four Seas Global Link Network Technology Co., Ltd
+ aka CF-E316V2, CF-E316N-V2 and CF-E316Nv2.0 (no FCC ID)
+endef
+
+$(eval $(call Profile,CF-E316N-V2))