aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:24:04 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:24:04 +0000
commit44ecb4d35d1e487fa9049642617034d676c1bf25 (patch)
treea2932f8593ee673a98d6a5596d3d98e3cb41989b /target/linux/ar71xx/generic
parent1c34671957be15a92a4e6797b502002b9898dc62 (diff)
downloadmaster-187ad058-44ecb4d35d1e487fa9049642617034d676c1bf25.tar.gz
master-187ad058-44ecb4d35d1e487fa9049642617034d676c1bf25.tar.bz2
master-187ad058-44ecb4d35d1e487fa9049642617034d676c1bf25.zip
ar71xx: add support for TP-Link TL-WDR6500 v2
Signed-off-by: Weijie Gao <hackpascal@gmail.com> This patch adds support for TP-Link TL-WDR6500 v2. The firmware has a U-Boot header for kernel, and a TP-LINK v2 header for the whole firmware, so I have to create a new firmware creation method. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46663 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 0174a431b1..05d10196d3 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -277,6 +277,17 @@ endef
$(eval $(call Profile,TLWDR4900V2))
+define Profile/TLWDR6500V2
+ NAME:=TP-LINK TL-WDR6500v2
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
+endef
+
+define Profile/TLWDR6500V2/Description
+ Package set optimized for the TP-LINK TL-WDR6500v2.
+endef
+$(eval $(call Profile,TLWDR6500V2))
+
+
define Profile/TLWR740
NAME:=TP-LINK TL-WR740N/ND
PACKAGES:=