aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-19 11:27:52 +0000
commit3c59b9c660f4e83f7d0ace2fdf491b58145f9df6 (patch)
tree396633aedbd7ad2dc684356be2894516276d7ba9 /target/linux/ar71xx/generic
parent4414a0da83877902e200dc84b76c21b7c6c6f8f5 (diff)
downloadmaster-187ad058-3c59b9c660f4e83f7d0ace2fdf491b58145f9df6.tar.gz
master-187ad058-3c59b9c660f4e83f7d0ace2fdf491b58145f9df6.tar.bz2
master-187ad058-3c59b9c660f4e83f7d0ace2fdf491b58145f9df6.zip
ar71xx: Image generation for PowerCloud CR5000 Cloud Router
Kernel part of support for the PowerCloud Systems CR5000. The CR5000 is a dual-band 802.11n wireless router with 8MB flash, 64 MB RAM, (unused in stock firmware) USB 2.0 port, and five port gigabit ethernet switch. The CR5000 was sold as hardware for the Skydog cloud-managed router service. Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47943 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/pcs.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/pcs.mk b/target/linux/ar71xx/generic/profiles/pcs.mk
index b4df1a4712..e48b3bd953 100644
--- a/target/linux/ar71xx/generic/profiles/pcs.mk
+++ b/target/linux/ar71xx/generic/profiles/pcs.mk
@@ -65,3 +65,21 @@ endef
$(eval $(call Profile,CR3000))
+define Profile/CR5000
+ NAME:=PowerCloud CR5000 Cloud Router
+ PACKAGES:=uboot-envtools kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev kmod-usb-core
+endef
+
+define Profile/CR5000/Description
+ Package set optimized for the PowerCloud Systems CR5000 Cloud Router
+
+ The CR5000 is a device sold by PowerCloud Systems as a hardware
+ option for their Skydog cloud-managed Wifi solution.
+
+ The CR5000 is a dual band GHz 802.11n wireless router with 8MB
+ flash and 64MB RAM, a five port gigabit switch and a USB 2.0
+ port which was unused in the stock firmware.
+endef
+
+$(eval $(call Profile,CR5000))
+