aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-27 08:59:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-27 08:59:53 +0000
commit06d41d3a2d6cf11327102ddc8eb2cefcf7bf0bbb (patch)
tree237e4f7ce565f6b8dbd2c96d14cddc90c9614d99 /target/linux/ar71xx/generic
parent5c61a3fe4affbe0a158bec02ebc0d587ec40ad21 (diff)
downloadmaster-187ad058-06d41d3a2d6cf11327102ddc8eb2cefcf7bf0bbb.tar.gz
master-187ad058-06d41d3a2d6cf11327102ddc8eb2cefcf7bf0bbb.tar.bz2
master-187ad058-06d41d3a2d6cf11327102ddc8eb2cefcf7bf0bbb.zip
Add support for Atheros AP96 reference board
This is still preliminary and not really tested much. Anyway, this version seems to be enough to get both wired and wireless interfaces working. Buttons and leds are also working. mach-ap96.c is based on mach-wndr3700.c. Signed-off-by: Jouni Malinen <jouni.malinen@atheros.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23125 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/atheros.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/atheros.mk b/target/linux/ar71xx/generic/profiles/atheros.mk
index 4ce0e605c6..97d5032574 100644
--- a/target/linux/ar71xx/generic/profiles/atheros.mk
+++ b/target/linux/ar71xx/generic/profiles/atheros.mk
@@ -28,6 +28,17 @@ endef
$(eval $(call Profile,AP83))
+define Profile/AP96
+ NAME:=Atheros AP96 reference board
+ PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+endef
+
+define Profile/AP96/Description
+ Package set optimized for the Atheros AP96 reference board.
+endef
+
+$(eval $(call Profile,AP96))
+
define Profile/PB42
NAME:=Atheros PB42 reference board
PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2