aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:54 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-07 13:46:54 +0000
commitef215c0518cec9db3801fc0c0d5aa859e500bb2f (patch)
tree77747dbbf6db6a66410777a47d58c7b1c2a89494 /target/linux/ar71xx/generic/profiles
parentd0b7d64c9dbe6ae3c42696470e60d7cf7baa78db (diff)
downloadmaster-187ad058-ef215c0518cec9db3801fc0c0d5aa859e500bb2f.tar.gz
master-187ad058-ef215c0518cec9db3801fc0c0d5aa859e500bb2f.tar.bz2
master-187ad058-ef215c0518cec9db3801fc0c0d5aa859e500bb2f.zip
ar71xx: Add Support for the Bitmain Antminer S3
This patch adds support for the Bitmain Antminer S3 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s3 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46236 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/antminer.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/antminer.mk b/target/linux/ar71xx/generic/profiles/antminer.mk
index 366982c885..404133b8ca 100644
--- a/target/linux/ar71xx/generic/profiles/antminer.mk
+++ b/target/linux/ar71xx/generic/profiles/antminer.mk
@@ -15,3 +15,14 @@ define Profile/ANTMINER_S1/Description
Package set optimized for the Bitmain Antminer S1.
endef
$(eval $(call Profile,ANTMINER_S1))
+
+define Profile/ANTMINER_S3
+ NAME:=Antminer S3
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINER_S1/Description
+ Package set optimized for the Bitmain Antminer S3.
+endef
+$(eval $(call Profile,ANTMINER_S3))