aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-26 07:32:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-26 07:32:01 +0000
commit455c0fd1910ec68cd3501f353d8dc9046ee97999 (patch)
tree55e0ccdffb3f75d6eabadaf744d70041b0c6885f /target/linux/ar71xx/generic/profiles
parentf0b89f8f09c64232771235e24507bc386e50609a (diff)
downloadmaster-187ad058-455c0fd1910ec68cd3501f353d8dc9046ee97999.tar.gz
master-187ad058-455c0fd1910ec68cd3501f353d8dc9046ee97999.tar.bz2
master-187ad058-455c0fd1910ec68cd3501f353d8dc9046ee97999.zip
ar71xx: add profile and fixup image generation for the TL-MR10U board
Create a separate board profile and update the profile name in image/makefile. Also use the correct machtype string in kernel command line. Based on andelf's patch: http://andelf.diandian.com/post/2013-05-22/40050677370 Signed-off-by: Oleg Titov <oleg.titov@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/3840/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37550 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 8c16df6a55..30e2b9cf2e 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -16,6 +16,17 @@ endef
$(eval $(call Profile,ARCHERC7))
+define Profile/TLMR10U
+ NAME:=TP-LINK TL-MR10U
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR10U/Description
+ Package set optimized for the TP-LINK TL-MR10U.
+endef
+$(eval $(call Profile,TLMR10U))
+
+
define Profile/TLMR11U
NAME:=TP-LINK TL-MR11U
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev