aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/qihoo.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-15 10:19:38 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-15 10:19:38 +0000
commitba33fec925ccd1a96921437a31a1ca49352d0595 (patch)
tree6eb9422e5ba65e6c4d3d53848fa53555b3c11dd6 /target/linux/ar71xx/generic/profiles/qihoo.mk
parentda18057e0514e7d80e81d9167b856bc20c4b12a9 (diff)
downloadmaster-187ad058-ba33fec925ccd1a96921437a31a1ca49352d0595.tar.gz
master-187ad058-ba33fec925ccd1a96921437a31a1ca49352d0595.tar.bz2
master-187ad058-ba33fec925ccd1a96921437a31a1ca49352d0595.zip
ar71xx: add qihoo 360 c301 router support
Qihoo 360 C301 is a dual band wireless router supports 802.11n and 802.11ac. Its chipset is AR9344 + AR9882 with two 16MB flashes. This patch adds its initial support. v2: * use mtd_get_mac_ascii to fetch MAC address for ath10k. * use ath79_register_pci to initialize AR9882. Signed-off-by: Weijie Gao <hackpascal@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42552 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/qihoo.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/qihoo.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/qihoo.mk b/target/linux/ar71xx/generic/profiles/qihoo.mk
new file mode 100644
index 0000000000..0ec778ab2b
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/qihoo.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/QIHOO360
+ NAME:=Qihoo 360 C301
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
+endef
+
+define Profile/QIHOO360/Description
+ Package set optimized for the Qihoo 360 C301 device.
+endef
+$(eval $(call Profile,QIHOO360))