aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/openembed.mk
diff options
context:
space:
mode:
authorAllan Nick Pedrana <nik9993@gmail.com>2016-06-22 14:22:05 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-22 14:22:05 +0200
commitbebdc8766a78b738039c4137e7315560cf0d52a6 (patch)
treee1fa6083bbb30e3662a65ca1fe69b22096a3959d /target/linux/ar71xx/generic/profiles/openembed.mk
parent1d3853d41f0f9971acb32a9e4ef29e97c4cdacc3 (diff)
downloadmaster-187ad058-bebdc8766a78b738039c4137e7315560cf0d52a6.tar.gz
master-187ad058-bebdc8766a78b738039c4137e7315560cf0d52a6.tar.bz2
master-187ad058-bebdc8766a78b738039c4137e7315560cf0d52a6.zip
ar71xx: add support for OpenEmbed SOM9331
This patch adds the target profile SOM9331 and configures hardware functionality for the 3x Eth Ports & corresponding LED's, the USB Host, the USART to USB bridge and the System LED. Signed-off-by: Allan Nick Pedrana <nik9993@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/openembed.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/openembed.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openembed.mk b/target/linux/ar71xx/generic/profiles/openembed.mk
new file mode 100644
index 0000000000..2603e0a4cb
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/openembed.mk
@@ -0,0 +1,13 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+define Profile/SOM9331
+ NAME:=OpenEmbed SOM9331
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-i2c-core kmod-i2c-gpio-custom kmod-spi-bitbang kmod-spi-dev kmod-spi-gpio kmod-spi-gpio-custom kmod-usb-serial
+endef
+
+define Profile/SOM9331/Description
+ Package set optimized for the OpenEmbed SOM9331.
+endef
+$(eval $(call Profile,SOM9331))
+