aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/netgear.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-12 16:49:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-12 16:49:52 +0000
commit250a19d0bc77429ab41c2bf962895a0d00407722 (patch)
tree15383c2a1644cd647f10d3f5fe2e362beb51241d /target/linux/ar71xx/generic/profiles/netgear.mk
parent8717323c7da68034f365a4c4aff2ad6d330ddefe (diff)
downloadmaster-187ad058-250a19d0bc77429ab41c2bf962895a0d00407722.tar.gz
master-187ad058-250a19d0bc77429ab41c2bf962895a0d00407722.tar.bz2
master-187ad058-250a19d0bc77429ab41c2bf962895a0d00407722.zip
ar71xx: add profile and build initramfs image for the WNDR4300
It is not yet possible to use the default squasfsh/jffs2 images on NAND flashes, so only initramfs image is supported for now. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34650 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/netgear.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
index fe136234f6..ff25f695a0 100644
--- a/target/linux/ar71xx/generic/profiles/netgear.mk
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,3 +15,16 @@ define Profile/WNDR3700/Description
endef
$(eval $(call Profile,WNDR3700))
+
+
+define Profile/WNDR4300
+ NAME:=NETGEAR WNDR4300
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+ Package set optimized for the NETGEAR WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
+