aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/netgear.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-13 14:59:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-13 14:59:40 +0000
commit041a6265f8c1a64d4b4ec32d8bcaababdf6e2baa (patch)
tree0e8289cdd8bcaadcaceff6a3722a9de26e9d1bc0 /target/linux/ar71xx/generic/profiles/netgear.mk
parent24713f9c5b42cb8dc0445146b726d2bd77086ad3 (diff)
downloadmaster-187ad058-041a6265f8c1a64d4b4ec32d8bcaababdf6e2baa.tar.gz
master-187ad058-041a6265f8c1a64d4b4ec32d8bcaababdf6e2baa.tar.bz2
master-187ad058-041a6265f8c1a64d4b4ec32d8bcaababdf6e2baa.zip
ar71xx: Build images for Netgear WNDRMAC and WNDRMACv2
The WNDRMAC is a WNDR3700v2 (64MB RAM, 16MB flash) in a white case. The WNDRMACv2 is a WNDR3800 (128MB RAM, 16MB flash) in a WNDRMAC case. The WNDRMAC case doesn't have "holes" or labels for the 2.4GHz LED or switch ports 2-4. The stock firmware uses a single LED (in the 5GHz position) to indicate the status of both radios, and a single LED (in the switch port 1 position) to indicate the status of all LAN ports. The "missing" LEDs are present on the board, and easily shine through the case. Unlike the stock firmware, OpenWrt will use these "hidden" LEDs. I've tested the WNDRMACv2 image. I don't have a v1 WNDRMAC, but assume that this is sufficient to build a fully-functional image. Signed-off-by: Mark Mentovai <mark@moxienet.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29513 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/netgear.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
index 78dba9762a..5978a32682 100644
--- a/target/linux/ar71xx/generic/profiles/netgear.mk
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -6,12 +6,12 @@
#
define Profile/WNDR3700
- NAME:=NETGEAR WNDR3700/3800
+ NAME:=NETGEAR WNDR3700/WNDR3800/WNDRMAC
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/WNDR3700/Description
- Package set optimized for the NETGEAR WNDR3700/3800
+ Package set optimized for the NETGEAR WNDR3700/WNDR3800/WNDRMAC
endef
$(eval $(call Profile,WNDR3700))