aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/engenius.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-07-14 10:25:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-07-14 10:25:53 +0000
commitd389a460cc8f421be34c0d1013a29d914d70e0ab (patch)
tree133607af08c97d7af2de7ca8fda03be5e805b5cc /target/linux/ar71xx/generic/profiles/engenius.mk
parentcb6fe2bf5b6b27e1ebd44d327e75767d5cc72649 (diff)
downloadmaster-187ad058-d389a460cc8f421be34c0d1013a29d914d70e0ab.tar.gz
master-187ad058-d389a460cc8f421be34c0d1013a29d914d70e0ab.tar.bz2
master-187ad058-d389a460cc8f421be34c0d1013a29d914d70e0ab.zip
ar71xx: add profile and build image for the EnGenius ESR900
Signed-off-by: Forest Crossman <cyrozap@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/5715/ [juhosg: change subject] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41642 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/engenius.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/engenius.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/engenius.mk b/target/linux/ar71xx/generic/profiles/engenius.mk
index e59428cc8f..093dfa47e9 100644
--- a/target/linux/ar71xx/generic/profiles/engenius.mk
+++ b/target/linux/ar71xx/generic/profiles/engenius.mk
@@ -4,6 +4,19 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+define Profile/ESR900
+ NAME:=EnGenius ESR900
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/ESR900/Description
+ Package set optimized for the EnGenius ESR900
+endef
+
+$(eval $(call Profile,ESR900))
+
+
define Profile/ESR1750
NAME:=EnGenius ESR1750
PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-ath10k wpad-mini