aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/d-link.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:09 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:09 +0000
commit780aecc9ca1d16c15695d001606ad4352b4c455e (patch)
treed71c5c4cc477c2a3dd0e3e16e4b161aeaa83e406 /target/linux/ar71xx/generic/profiles/d-link.mk
parent0e45b3367c633bec0f1b67d2a50ec0c23999f7e5 (diff)
downloadmaster-187ad058-780aecc9ca1d16c15695d001606ad4352b4c455e.tar.gz
master-187ad058-780aecc9ca1d16c15695d001606ad4352b4c455e.tar.bz2
master-187ad058-780aecc9ca1d16c15695d001606ad4352b4c455e.zip
ar71xx: support for D-LINK DIR-615 rev. E4
This patch adds support for D-LINK DIR-615 E4 board. It's mostly based on the existing support for DIR-600 A1, with some changes in the leds configuration. It's an updated version of the patch that reliably works on my hw for about a year (it was built from trunk on Jan 2011). When I decided to update the firmware and checked for the current support for that device, I also found previously posted patches by Alexey Loukianov that mentioned some stability issues. I'm not sure where could be the difference, the patches are very similar except the wmac led pin number - I was using 1, and those patches used 17. [juhosg: add 3.2 support] Signed-off-by: Vadim Girlin <vadimgirlin@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29973 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/d-link.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/d-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/d-link.mk b/target/linux/ar71xx/generic/profiles/d-link.mk
index ec79ddecf4..3068c4f31a 100644
--- a/target/linux/ar71xx/generic/profiles/d-link.mk
+++ b/target/linux/ar71xx/generic/profiles/d-link.mk
@@ -29,6 +29,18 @@ endef
$(eval $(call Profile,DIR615C1))
+define Profile/DIR615E4
+ NAME:=D-Link DIR-615 rev. E4
+ PACKAGES:=
+endef
+
+define Profile/DIR615E4/Description
+ Package set optimized for the D-Link DIR-615 rev. E4.
+endef
+
+$(eval $(call Profile,DIR615E4))
+
+
define Profile/DIR825B1
NAME:=D-Link DIR-825 rev. B1
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev