aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/d-link.mk
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2012-09-17 14:17:12 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2012-09-17 14:17:12 +0000
commit4ea95cae7d2e182daf804f8b29f303b455b53cea (patch)
tree9164a0bfe89c830f217e433bd8d203cda623421a /target/linux/ar71xx/generic/profiles/d-link.mk
parent0611e73d533c9ddbe8fa870fe64c17ab94a3e185 (diff)
downloadmaster-187ad058-4ea95cae7d2e182daf804f8b29f303b455b53cea.tar.gz
master-187ad058-4ea95cae7d2e182daf804f8b29f303b455b53cea.tar.bz2
master-187ad058-4ea95cae7d2e182daf804f8b29f303b455b53cea.zip
[ar71xx] dir-825-b1: Fix wholeflash images: Attempting to flash a wholeflash (-openwrt) image from the normal image would brick (but recoverable via emergency flash) the router if the wholeflash image was larger than the maximum size for a normal image. First we rename the -openwrt images to -wholeflash since -openwrt is really too generic. We also revert the changes to the regular dir-825-b1 image, which now is the same as before, but add a -towholeflash image which is almost the same as the regular dir-825-b1 image, but copies caldata to new location and allows flashing of images that use the full flash (except u-boot, u-boot-env, and caldata paritition space) (these are the -wholeflash images).
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33447 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/d-link.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/d-link.mk32
1 files changed, 25 insertions, 7 deletions
diff --git a/target/linux/ar71xx/generic/profiles/d-link.mk b/target/linux/ar71xx/generic/profiles/d-link.mk
index 1691cade2f..8fcc77f0f1 100644
--- a/target/linux/ar71xx/generic/profiles/d-link.mk
+++ b/target/linux/ar71xx/generic/profiles/d-link.mk
@@ -68,28 +68,46 @@ endef
define Profile/DIR825B1/Description
Package set optimized for the D-Link DIR-825 rev. B1.
+ WARNING: Flashing wholeflash (openwrt optimized) image may brick your router
+ . This will occur if your openwrt optimized image is larger than the
+ maximum size for a regular dir-825 b1 image (a little more than 6MB).
+ Please flash a TOWHOLEFLASH image instead of this image before flashing
+a
+ WHOLEFLASH image.
+endef
+
+$(eval $(call Profile,DIR825B1))
+
+define Profile/DIR825B1_TOWHOLEFLASH
+ NAME:=D-Link DIR-825 rev. B1 designed for transition to image using whole flash
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825B1_TOWHOLEFLASH/Description
+ Package set optimized for the D-Link DIR-825 rev. B1. design for transtion to
+ image using whole flash.
Copies the calibration data to the last erase block so that, if desired,
an image optimized for use with OpenWrt (access to full flash) can be flashed.
endef
-$(eval $(call Profile,DIR825B1))
+$(eval $(call Profile,DIR825B1_TOWHOLEFLASH))
-define Profile/DIR825B1_OPENWRT
- NAME:=D-Link DIR-825 rev. B1 optimized for OpenWrt
+define Profile/DIR825B1_WHOLEFLASH
+ NAME:=D-Link DIR-825 rev. B1 optimized for OpenWrt which uses full 8M flash
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
endef
-define Profile/DIR825B1_OPENWRT/Description
- Package set optimized for the D-Link DIR-825 rev. B1. running OpenWrt
+define Profile/DIR825B1_WHOLEFLASH/Description
+ Package set optimized for the D-Link DIR-825 rev. B1. using wholeflash
Can only be flashed from OpenWrt because it requires that the calibration data
be on the last sector of the flash (which the 'standard' version that can be flashed from
stock will ensure).
endef
-$(eval $(call Profile,DIR825B1_OPENWRT))
+$(eval $(call Profile,DIR825B1_WHOLEFLASH))
define Profile/DIR825B1_TOSTOCK
- NAME:=D-Link DIR-825 rev. B1 that undoes OpenWrt optimization
+ NAME:=D-Link DIR-825 rev. B1 that undoes OpenWrt optimization (i.e. wholeflash)
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
endef