aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/bhu.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:59 +0000
commita82dc55eca9ad63f92e4d7b7a09fcd84c1b3affe (patch)
tree6e6da95878c21be44a11616e0bfb67346fbd1b6c /target/linux/ar71xx/generic/profiles/bhu.mk
parent8ef73de0f68970885f302f0caa367bec6ae5c3fc (diff)
downloadmaster-187ad058-a82dc55eca9ad63f92e4d7b7a09fcd84c1b3affe.tar.gz
master-187ad058-a82dc55eca9ad63f92e4d7b7a09fcd84c1b3affe.tar.bz2
master-187ad058-a82dc55eca9ad63f92e4d7b7a09fcd84c1b3affe.zip
ar71xx: add profile and build image for the BXU2000n-2 A1 board
Patchwork: http://patchwork.openwrt.org/patch/4183/ Signed-off-by: Terry Yang <yangbo@bhunetworks.com> [juhosg: - remove MultiProfile, it makes no sense for a single board - move SingleProfile call and the mtdlayout to a different location keep things sorted (well, almost)] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38593 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/bhu.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/bhu.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/bhu.mk b/target/linux/ar71xx/generic/profiles/bhu.mk
new file mode 100644
index 0000000000..f21b3c38d9
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/bhu.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 BHU Networks.
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BXU2000N2
+ NAME:=BHU BXU2000n-2
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/BXU2000N2/Description
+ Package set optimized for the BHU BXU2000n-2.
+endef
+
+$(eval $(call Profile,BXU2000N2))