aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/allnet.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-08-27 14:55:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-08-27 14:55:38 +0000
commit6a0998c459a4f47a5666e280c9f698c414ba1bb7 (patch)
tree96f5833b44643006bab2b32f51d97c247c55c758 /target/linux/ar71xx/generic/profiles/allnet.mk
parent268ef7af3314e0e14789e512da0c5411a9972ecb (diff)
downloadmaster-187ad058-6a0998c459a4f47a5666e280c9f698c414ba1bb7.tar.gz
master-187ad058-6a0998c459a4f47a5666e280c9f698c414ba1bb7.tar.bz2
master-187ad058-6a0998c459a4f47a5666e280c9f698c414ba1bb7.zip
ar71xx: add profile for Allnet devices
Signed-off-by: Daniel Golle <dgolle@allnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33287 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/allnet.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/allnet.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/allnet.mk b/target/linux/ar71xx/generic/profiles/allnet.mk
new file mode 100644
index 0000000000..986b633533
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/allnet.mk
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 20012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ALL0305
+ NAME:=Allnet ALL0305
+ PACKAGES:=fconfig kmod-ath5k -kmod-ath9k
+endef
+
+define Profile/ALL0305/Description
+ Package set optimized for the Allnet ALL0305.
+endef
+
+$(eval $(call Profile,ALL0305))
+
+define Profile/ALL0258N
+ NAME:=Allnet ALL0258N
+ PACKAGES:=uboot-envtools
+endef
+
+define Profile/ALL0258N/Description
+ Package set optimized for the Allnet ALL0258N.
+endef
+
+$(eval $(call Profile,ALL0258N))
+
+define Profile/ALL0315N
+ NAME:=Allnet ALL0315N
+ PACKAGES:=uboot-envtools
+endef
+
+define Profile/ALL0315N/Description
+ Package set optimized for the Allnet ALL0315N.
+endef
+
+$(eval $(call Profile,ALL0315N))