aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-01-01 21:21:13 +0000
committerJohn Crispin <blogic@openwrt.org>2016-01-01 21:21:13 +0000
commit9b0602dd3afe5e03cd6284ee39d54f8238fd64be (patch)
tree75539893347c0523c86e60618fc1f9d0d6457fdc /target/linux/ar71xx/files
parentaa826858305e1797546d3a50c94905be24a55c31 (diff)
downloadmaster-187ad058-9b0602dd3afe5e03cd6284ee39d54f8238fd64be.tar.gz
master-187ad058-9b0602dd3afe5e03cd6284ee39d54f8238fd64be.tar.bz2
master-187ad058-9b0602dd3afe5e03cd6284ee39d54f8238fd64be.zip
V2 ar71xx : Add Support for the Bitmain Antrouter R1
This patch adds support for the Bitmain Antrouter R1 http://wiki.openwrt.org/toh/bitmain/r1 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48058 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/files')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-antrouter-r1.c98
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 110 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 84d22fe7a0..cdd4fa2dc2 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -72,6 +72,16 @@ config ATH79_MACH_ANTMINER_S3
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_ANTROUTER_R1
+ bool "Bitmain Antrouter R1 support"
+ select SOC_AR933X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_ARDUINO_YUN
bool "Arduino Yun"
select SOC_AR933X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 2d4522551a..991f6f2aa5 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -44,6 +44,7 @@ obj-$(CONFIG_ATH79_MACH_ALL0258N) += mach-all0258n.o
obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
obj-$(CONFIG_ATH79_MACH_ANTMINER_S1)+= mach-antminer-s1.o
obj-$(CONFIG_ATH79_MACH_ANTMINER_S3)+= mach-antminer-s3.o
+obj-$(CONFIG_ATH79_MACH_ANTROUTER_R1) += mach-antrouter-r1.o
obj-$(CONFIG_ATH79_MACH_ARDUINO_YUN) += mach-arduino-yun.o
obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-antrouter-r1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-antrouter-r1.c
new file mode 100644
index 0000000000..a8f7b5d687
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-antrouter-r1.c
@@ -0,0 +1,98 @@
+/*
+ * Bitmain Antrouter R1 board support
+ *
+ * Copyright (C) 2015 L. D. Pinney <ldpinney@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "dev-usb.h"
+
+#define ANTROUTER_R1_GPIO_BTN_RESET 11
+
+#define ANTROUTER_R1_GPIO_LED_WLAN 0
+#define ANTROUTER_R1_GPIO_LED_BTC 22
+#define ANTROUTER_R1_GPIO_USB_POWER 18
+
+#define ANTROUTER_R1_KEYSPOLL_INTERVAL 44 /* msecs */
+#define ANTROUTER_R1_KEYSDEBOUNCE_INTERVAL (4 * ANTROUTER_R1_KEYSPOLL_INTERVAL)
+
+static const char *ANTROUTER_R1_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data ANTROUTER_R1_flash_data = {
+ .part_probes = ANTROUTER_R1_part_probes,
+};
+
+static struct gpio_led ANTROUTER_R1_leds_gpio[] __initdata = {
+ {
+ .name = "antrouter-r1:green:wlan",
+ .gpio = ANTROUTER_R1_GPIO_LED_WLAN,
+ .active_low = 0,
+ },{
+ .name = "antrouter-r1:green:system",
+ .gpio = ANTROUTER_R1_GPIO_LED_BTC,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button ANTROUTER_R1_GPIO_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = ANTROUTER_R1_KEYSDEBOUNCE_INTERVAL,
+ .gpio = ANTROUTER_R1_GPIO_BTN_RESET,
+ .active_low = 0,
+ },
+};
+
+static void __init antrouter_r1_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+ /* disable PHY_SWAP and PHY_ADDR_SWAP bits */
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(ANTROUTER_R1_leds_gpio),
+ ANTROUTER_R1_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, ANTROUTER_R1_KEYSPOLL_INTERVAL,
+ ARRAY_SIZE(ANTROUTER_R1_GPIO_keys),
+ ANTROUTER_R1_GPIO_keys);
+
+ gpio_request_one(ANTROUTER_R1_GPIO_USB_POWER,
+ GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+ "USB power");
+ ath79_register_usb();
+
+ ath79_register_m25p80(&ANTROUTER_R1_flash_data);
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
+
+ ath79_register_mdio(0, 0x0);
+ ath79_register_eth(0);
+ ath79_register_eth(1);
+
+ ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_ANTROUTER_R1, "ANTROUTER-R1",
+ "Antrouter-R1", antrouter_r1_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index c32d44a73a..d12829f4de 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -23,6 +23,7 @@ enum ath79_mach_type {
ATH79_MACH_ALL0315N, /* Allnet ALL0315N */
ATH79_MACH_ANTMINER_S1, /* Antminer S1 */
ATH79_MACH_ANTMINER_S3, /* Antminer S3 */
+ ATH79_MACH_ANTROUTER_R1, /* Antrouter R1 */
ATH79_MACH_ARDUINO_YUN, /* Yun */
ATH79_MACH_AP113, /* Atheros AP113 reference board */
ATH79_MACH_AP121, /* Atheros AP121 reference board */