aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-17 09:30:05 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-17 09:30:05 +0000
commitd7afba0d5820fb2a3a2a4a16393922615ccc15c8 (patch)
tree6eedf5db17155f8de32ec9757180900ed72d134f /target/linux/ar71xx/files/arch/mips
parent61b9031f7b99679ce1a95a7f9f995d47ca1d0515 (diff)
downloadmaster-187ad058-d7afba0d5820fb2a3a2a4a16393922615ccc15c8.tar.gz
master-187ad058-d7afba0d5820fb2a3a2a4a16393922615ccc15c8.tar.bz2
master-187ad058-d7afba0d5820fb2a3a2a4a16393922615ccc15c8.zip
ar71xx: add support for TRENDnet TEW-823DRU
Add support for TRENDnet TEW-823DRU: - cpu: QCA9558 @720MHz - flash: 16MB - ram: 256MB - 4+1 RJ45 100/1000Mbps - wifi: QCA9558 (bgn) and QCA9880-BR4A (ac) - 1x USB 2.0 Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47927 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tew-823dru.c181
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 193 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 2b62d89d59..d619b3cf1e 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1279,6 +1279,16 @@ config ATH79_MACH_TEW_732BR
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_TEW_823DRU
+ bool "TRENDnet TEW-823DRU support"
+ select SOC_QCA955X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_UBNT
bool "Ubiquiti AR71xx based boards support"
select SOC_AR71XX
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index f9c5b8fb9e..9f67bd8bde 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -129,6 +129,7 @@ obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
obj-$(CONFIG_ATH79_MACH_TEW_712BR) += mach-tew-712br.o
obj-$(CONFIG_ATH79_MACH_TEW_732BR) += mach-tew-732br.o
+obj-$(CONFIG_ATH79_MACH_TEW_823DRU) += mach-tew-823dru.o
obj-$(CONFIG_ATH79_MACH_TL_MR11U) += mach-tl-mr11u.o
obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mach-tl-mr13u.o
obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tew-823dru.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tew-823dru.c
new file mode 100644
index 0000000000..cf863ac666
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tew-823dru.c
@@ -0,0 +1,181 @@
+/*
+ * TRENDnet TEW-823DRU board support
+ *
+ * Copyright (C) 2015 Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
+ * Copyright (C) 2014 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2014 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TEW_823DRU_GPIO_LED_POWER_ORANGE 14
+#define TEW_823DRU_GPIO_LED_POWER_GREEN 19
+#define TEW_823DRU_GPIO_LED_PLANET_GREEN 22
+#define TEW_823DRU_GPIO_LED_PLANET_ORANGE 23
+
+#define TEW_823DRU_GPIO_BTN_WPS 16
+#define TEW_823DRU_GPIO_BTN_RESET 17
+
+#define TEW_823DRU_KEYS_POLL_INTERVAL 20 /* msecs */
+#define TEW_823DRU_KEYS_DEBOUNCE_INTERVAL \
+ (3 * TEW_823DRU_KEYS_POLL_INTERVAL)
+
+#define TEW_823DRU_WMAC_CALDATA_OFFSET 0x1000
+
+#define TEW_823DRU_LAN_MAC_OFFSET 0x04
+#define TEW_823DRU_WAN_MAC_OFFSET 0x18
+
+static struct gpio_led tew_823dru_leds_gpio[] __initdata = {
+ {
+ .name = "trendnet:green:power",
+ .gpio = TEW_823DRU_GPIO_LED_POWER_GREEN,
+ .active_low = 1,
+ },
+ {
+ .name = "trendnet:orange:power",
+ .gpio = TEW_823DRU_GPIO_LED_POWER_ORANGE,
+ .active_low = 1,
+ },
+ {
+ .name = "trendnet:green:planet",
+ .gpio = TEW_823DRU_GPIO_LED_PLANET_GREEN,
+ .active_low = 1,
+ },
+ {
+ .name = "trendnet:orange:planet",
+ .gpio = TEW_823DRU_GPIO_LED_PLANET_ORANGE,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button tew_823dru_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = TEW_823DRU_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TEW_823DRU_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+ {
+ .desc = "WPS button",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = TEW_823DRU_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TEW_823DRU_GPIO_BTN_WPS,
+ .active_low = 1,
+ },
+};
+
+/* GMAC0 of the AR8327 switch is connected to the QCA9558 SoC via SGMII */
+static struct ar8327_pad_cfg tew_823dru_ar8327_pad0_cfg = {
+ .mode = AR8327_PAD_MAC_SGMII,
+ .sgmii_delay_en = true,
+};
+
+/* GMAC6 of the AR8327 switch is connected to the QCA9558 SoC via RGMII */
+static struct ar8327_pad_cfg tew_823dru_ar8327_pad6_cfg = {
+ .mode = AR8327_PAD_MAC_RGMII,
+ .txclk_delay_en = true,
+ .rxclk_delay_en = true,
+ .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+ .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+};
+
+static struct ar8327_platform_data tew_823dru_ar8327_data = {
+ .pad0_cfg = &tew_823dru_ar8327_pad0_cfg,
+ .pad6_cfg = &tew_823dru_ar8327_pad6_cfg,
+ .port0_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+ .port6_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+};
+
+static struct mdio_board_info tew_823dru_mdio0_info[] = {
+ {
+ .bus_id = "ag71xx-mdio.0",
+ .phy_addr = 0,
+ .platform_data = &tew_823dru_ar8327_data,
+ },
+};
+
+static void __init tew_823dru_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1ffe0000);
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+ u8 lan_mac[ETH_ALEN];
+ u8 wan_mac[ETH_ALEN];
+
+ ath79_parse_ascii_mac(mac + TEW_823DRU_LAN_MAC_OFFSET, lan_mac);
+ ath79_parse_ascii_mac(mac + TEW_823DRU_WAN_MAC_OFFSET, wan_mac);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(tew_823dru_leds_gpio),
+ tew_823dru_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, TEW_823DRU_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(tew_823dru_gpio_keys),
+ tew_823dru_gpio_keys);
+
+ ath79_register_wmac(art + TEW_823DRU_WMAC_CALDATA_OFFSET, lan_mac);
+
+ ath79_init_mac(ath79_eth1_data.mac_addr, lan_mac, 0);
+ ath79_init_mac(ath79_eth0_data.mac_addr, wan_mac, 0);
+
+
+ mdiobus_register_board_info(tew_823dru_mdio0_info,
+ ARRAY_SIZE(tew_823dru_mdio0_info));
+ ath79_register_mdio(0, 0x0);
+
+ ath79_setup_qca955x_eth_cfg(QCA955X_ETH_CFG_RGMII_EN);
+
+ /* GMAC0 is connected to the RMGII interface */
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+ ath79_eth0_pll_data.pll_1000 = 0x56000000;
+
+ ath79_register_eth(0);
+
+ /* GMAC1 is connected to the SGMII interface */
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+ ath79_eth1_data.speed = SPEED_1000;
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_pll_data.pll_1000 = 0x03000101;
+
+ ath79_register_eth(1);
+
+ ath79_register_usb();
+ ath79_register_pci();
+}
+
+MIPS_MACHINE(ATH79_MACH_TEW_823DRU, "TEW-823DRU", "TRENDnet TEW-823DRU",
+ tew_823dru_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 2ea772d061..fc3eeaf838 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -142,6 +142,7 @@ enum ath79_mach_type {
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
ATH79_MACH_TEW_712BR, /* TRENDnet TEW-712BR */
ATH79_MACH_TEW_732BR, /* TRENDnet TEW-732BR */
+ ATH79_MACH_TEW_823DRU, /* TRENDnet TEW-823DRU */
ATH79_MACH_MC_MAC1200R, /* MERCURY MAC1200R*/
ATH79_MACH_TL_MR10U, /* TP-LINK TL-MR10U */
ATH79_MACH_TL_MR11U, /* TP-LINK TL-MR11U */