aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr13u.c
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-19 17:52:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-19 17:52:41 +0000
commitc5895925641401de176a6a51dd836edf1cc1d64c (patch)
tree3de22c521e07cffe2841be42bca6a94361f437a8 /target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr13u.c
parentff7456046021f02165b57d0ef63865c7ff91c3c8 (diff)
downloadmaster-187ad058-c5895925641401de176a6a51dd836edf1cc1d64c.tar.gz
master-187ad058-c5895925641401de176a6a51dd836edf1cc1d64c.tar.bz2
master-187ad058-c5895925641401de176a6a51dd836edf1cc1d64c.zip
ar71xx: add kernel support for TP-Link TL-MR13U
This patch adds support for TP-Link TL-MR13U router with built-in 10AH rechargeable battery. The patch is based on kamwanlai's patch: https://forum.openwrt.org/viewtopic.php?pid=206746#p206746 Updated to accommodate recent changes introduced with: ar71xx: remove fs_* variables from image/Makefile Signed-off-by: Oleg Titov <oleg.titov@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/4063/ [juhosg: - refresh and rename rename 930-add-tl-mr13u-support.patch => 625-MIPS-ath79-add-tl-mr13u-support.patch] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38063 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr13u.c')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr13u.c107
1 files changed, 107 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr13u.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr13u.c
new file mode 100644
index 0000000000..8b036457a7
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-mr13u.c
@@ -0,0 +1,107 @@
+/*
+ * TP-LINK TL-MR13U board support
+ *
+ * Copyright (C) 2011 dongyuqi <729650915@qq.com>
+ * Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TL_MR13U_GPIO_LED_SYSTEM 27
+
+#define TL_MR13U_GPIO_BTN_RESET 11
+#define TL_MR13U_GPIO_BTN_SW1 6
+#define TL_MR13U_GPIO_BTN_SW2 7
+
+#define TL_MR13U_GPIO_USB_POWER 18
+
+#define TL_MR13U_KEYS_POLL_INTERVAL 20 /* msecs */
+#define TL_MR13U_KEYS_DEBOUNCE_INTERVAL (3 * TL_MR13U_KEYS_POLL_INTERVAL)
+
+static const char *tl_mr13u_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data tl_mr13u_flash_data = {
+ .part_probes = tl_mr13u_part_probes,
+};
+
+static struct gpio_led tl_mr13u_leds_gpio[] __initdata = {
+ {
+ .name = "tp-link:blue:system",
+ .gpio = TL_MR13U_GPIO_LED_SYSTEM,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button tl_mr13u_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = TL_MR13U_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_MR13U_GPIO_BTN_RESET,
+ .active_low = 0,
+ },
+ {
+ .desc = "sw1",
+ .type = EV_KEY,
+ .code = BTN_0,
+ .debounce_interval = TL_MR13U_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_MR13U_GPIO_BTN_SW1,
+ .active_low = 0,
+ },
+ {
+ .desc = "sw2",
+ .type = EV_KEY,
+ .code = BTN_1,
+ .debounce_interval = TL_MR13U_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_MR13U_GPIO_BTN_SW2,
+ .active_low = 0,
+ },
+};
+
+static void __init tl_mr13u_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+ /* disable PHY_SWAP and PHY_ADDR_SWAP bits */
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_m25p80(&tl_mr13u_flash_data);
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(tl_mr13u_leds_gpio),
+ tl_mr13u_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, TL_MR13U_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(tl_mr13u_gpio_keys),
+ tl_mr13u_gpio_keys);
+
+ gpio_request_one(TL_MR13U_GPIO_USB_POWER,
+ GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+ "USB power");
+ ath79_register_usb();
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+
+ ath79_register_mdio(0, 0x0);
+ ath79_register_eth(0);
+ ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_MR13U, "TL-MR13U", "TP-LINK TL-MR13U v1",
+ tl_mr13u_setup);