aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/base-files/etc/diag.sh
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 17:55:25 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 17:55:25 +0000
commitdfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3 (patch)
tree12e48ac4df23edfd912270c88c4765cff5e30969 /target/linux/ar71xx/base-files/etc/diag.sh
parent1730dcd62fdeb38149daee4abce497b5be201435 (diff)
downloadmaster-187ad058-dfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3.tar.gz
master-187ad058-dfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3.tar.bz2
master-187ad058-dfd6005e5a4ebdc3e3bd97ead8d0c639582ee9b3.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to trunk
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox into trunk (or 'Designated Driver' :D ). Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners on 15.05. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47234 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/base-files/etc/diag.sh')
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index b2f77a007d..1375f38b79 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -227,6 +227,9 @@ get_status_led() {
smart-300)
status_led="nc-link:green:system"
;;
+ minibox-v1)
+ status_led="minibox-v1:green:system"
+ ;;
oolite)
status_led="oolite:red:system"
;;