aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-09 23:32:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-09 23:32:46 +0000
commitec3d195535544667d162190838144b7c443ffc06 (patch)
tree479d4cd565de34292178bdbd5633995a380ca34e /target/linux/ar71xx/Makefile
parente358500854bf063aeeefd68db743fb72ef388d6c (diff)
downloadmaster-187ad058-ec3d195535544667d162190838144b7c443ffc06.tar.gz
master-187ad058-ec3d195535544667d162190838144b7c443ffc06.tar.bz2
master-187ad058-ec3d195535544667d162190838144b7c443ffc06.zip
ar71xx: set mips16 support, tune cflags for 34kc (works well on MIPS 24K as well, but helps a lot for 34K and 74K)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36600 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/Makefile')
-rw-r--r--target/linux/ar71xx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 83b238e584..600b21d430 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
ARCH:=mips
BOARD:=ar71xx
BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs jffs2 targz mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand
LINUX_VERSION:=3.8.12