aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
commit7670811acd1d81f4e97d3c718d9edcac92ca9278 (patch)
tree10ae3895974888be85ce09abee24fe67b5fbd813 /target/linux/ar71xx/Makefile
parent2d285a2fb74e6fcbf021c752f70a7430a798fca3 (diff)
downloadmaster-187ad058-7670811acd1d81f4e97d3c718d9edcac92ca9278.tar.gz
master-187ad058-7670811acd1d81f4e97d3c718d9edcac92ca9278.tar.bz2
master-187ad058-7670811acd1d81f4e97d3c718d9edcac92ca9278.zip
surprise :p
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11894 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/Makefile')
-rw-r--r--target/linux/ar71xx/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
new file mode 100644
index 0000000000..849f4c2155
--- /dev/null
+++ b/target/linux/ar71xx/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ar71xx
+BOARDNAME:=Atheros AR71xx
+FEATURES:=squashfs tgz broken
+
+LINUX_VERSION:=2.6.25.10
+
+include $(INCLUDE_DIR)/target.mk
+
+#DEFAULT_PACKAGES += kmod-madwifi
+
+define Target/Description
+ Build firmware images for Atheros AR71xx based boards
+endef
+
+$(eval $(call BuildTarget))