aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-3.10/110-flash.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-10-12 10:50:44 +0000
committerJonas Gorski <jogo@openwrt.org>2013-10-12 10:50:44 +0000
commit2b6cea4a6e3b71dbfc8ae51775310933aae796b6 (patch)
tree904dffa29a1d5e05570e553fd99318227240fdd0 /target/linux/ar7/patches-3.10/110-flash.patch
parent33018b3e4563d074d27312a92e34b3f8e05b1b73 (diff)
downloadmaster-187ad058-2b6cea4a6e3b71dbfc8ae51775310933aae796b6.tar.gz
master-187ad058-2b6cea4a6e3b71dbfc8ae51775310933aae796b6.tar.bz2
master-187ad058-2b6cea4a6e3b71dbfc8ae51775310933aae796b6.zip
ar7: add support for linux 3.10 and switch to it
Run tested on WAG354Gv2. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-3.10/110-flash.patch')
-rw-r--r--target/linux/ar7/patches-3.10/110-flash.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-3.10/110-flash.patch b/target/linux/ar7/patches-3.10/110-flash.patch
new file mode 100644
index 0000000000..18ae78bfb6
--- /dev/null
+++ b/target/linux/ar7/patches-3.10/110-flash.patch
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -15,7 +15,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+-obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
++obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
+@@ -199,7 +199,7 @@ static struct resource physmap_flash_res
+ .name = "mem",
+ .flags = IORESOURCE_MEM,
+ .start = 0x10000000,
+- .end = 0x107fffff,
++ .end = 0x11ffffff,
+ };
+
+ static const char *ar7_probe_types[] = { "ar7part", NULL };