aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.32/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-02-04 14:35:26 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-02-04 14:35:26 +0000
commita4e122898c14775f523cfdf4b237dfe892b62931 (patch)
tree63a51f9f733b0ae08b22f6c9ac7b74d74b85eff7 /target/linux/ar7/patches-2.6.32/120-gpio_chrdev.patch
parentc435cb729697d9088dcfe06ab5f74d5480e90575 (diff)
downloadmaster-187ad058-a4e122898c14775f523cfdf4b237dfe892b62931.tar.gz
master-187ad058-a4e122898c14775f523cfdf4b237dfe892b62931.tar.bz2
master-187ad058-a4e122898c14775f523cfdf4b237dfe892b62931.zip
[ar7] add 2.6.32 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19519 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-2.6.32/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-2.6.32/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-2.6.32/120-gpio_chrdev.patch b/target/linux/ar7/patches-2.6.32/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..d648d08c8d
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.32/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -987,6 +987,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -92,6 +92,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o