aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.25/110-flash.patch
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2008-05-03 15:33:38 +0000
committerMatteo Croce <matteo@openwrt.org>2008-05-03 15:33:38 +0000
commita99406498666558fdba17394c6aa6f6b576113c4 (patch)
tree2d166d7b5075c536927041f2ac9a7d6c1f35f771 /target/linux/ar7/patches-2.6.25/110-flash.patch
parent6c355a128a1fc67c845235448702be2b36a1debc (diff)
downloadmaster-187ad058-a99406498666558fdba17394c6aa6f6b576113c4.tar.gz
master-187ad058-a99406498666558fdba17394c6aa6f6b576113c4.tar.bz2
master-187ad058-a99406498666558fdba17394c6aa6f6b576113c4.zip
ar7: 2.6.25.1 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11023 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-2.6.25/110-flash.patch')
-rw-r--r--target/linux/ar7/patches-2.6.25/110-flash.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-2.6.25/110-flash.patch b/target/linux/ar7/patches-2.6.25/110-flash.patch
new file mode 100644
index 0000000000..02f8d952f0
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.25/110-flash.patch
@@ -0,0 +1,43 @@
+Index: linux-2.6.25.1/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/Kconfig 2008-05-01 23:45:25.000000000 +0200
++++ linux-2.6.25.1/drivers/mtd/Kconfig 2008-05-03 16:18:06.000000000 +0200
+@@ -158,6 +158,12 @@
+ the partition map from the children of the flash node,
+ as described in Documentation/powerpc/booting-without-of.txt.
+
++config MTD_AR7_PARTS
++ tristate "TI AR7 partitioning support"
++ depends on MTD_PARTITIONS
++ ---help---
++ TI AR7 partitioning support
++
+ comment "User Modules And Translation Layers"
+
+ config MTD_CHAR
+Index: linux-2.6.25.1/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/Makefile 2008-05-01 23:45:25.000000000 +0200
++++ linux-2.6.25.1/drivers/mtd/Makefile 2008-05-03 16:18:06.000000000 +0200
+@@ -12,6 +12,7 @@
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
++obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o
+Index: linux-2.6.25.1/drivers/mtd/maps/physmap.c
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/maps/physmap.c 2008-05-01 23:45:25.000000000 +0200
++++ linux-2.6.25.1/drivers/mtd/maps/physmap.c 2008-05-03 16:18:06.000000000 +0200
+@@ -87,7 +87,8 @@
+
+ static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
+ #ifdef CONFIG_MTD_PARTITIONS
+-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
++static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
++ "ar7part", NULL };
+ #endif
+
+ static int physmap_flash_probe(struct platform_device *dev)