aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amcc-2.6/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-06-05 20:55:21 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-06-05 20:55:21 +0000
commit12d1bd76b08361b0d067af9b37fffb32d34fc5a1 (patch)
tree9ca0bc5a0c5feed217f8303abe6eedeb847ec38f /target/linux/amcc-2.6/image/Makefile
parent4946efff6bd18cc99acd94f3bfbddbf99cbb9196 (diff)
downloadmaster-187ad058-12d1bd76b08361b0d067af9b37fffb32d34fc5a1.tar.gz
master-187ad058-12d1bd76b08361b0d067af9b37fffb32d34fc5a1.tar.bz2
master-187ad058-12d1bd76b08361b0d067af9b37fffb32d34fc5a1.zip
add support for jffs2 filesystems with 256k blocksize, fix taishan support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7506 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/amcc-2.6/image/Makefile')
-rw-r--r--target/linux/amcc-2.6/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/amcc-2.6/image/Makefile b/target/linux/amcc-2.6/image/Makefile
index bab2e647ee..bd391f02f2 100644
--- a/target/linux/amcc-2.6/image/Makefile
+++ b/target/linux/amcc-2.6/image/Makefile
@@ -19,6 +19,13 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
+define Image/Build/jffs2-256k
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-jffs2.img
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \