aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-12-06 22:40:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-12-06 22:40:54 +0000
commit2584cf2010fac9fb40154e70727354d4ee581acb (patch)
tree2a93a3c54f2b0567878c665789acaee51c10024d /target/linux/adm8668
parent171050a53c1ad368671b29c1f58109d946159a3c (diff)
downloadmaster-187ad058-2584cf2010fac9fb40154e70727354d4ee581acb.tar.gz
master-187ad058-2584cf2010fac9fb40154e70727354d4ee581acb.tar.bz2
master-187ad058-2584cf2010fac9fb40154e70727354d4ee581acb.zip
[adm8668] enable and advertise USB support
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34562 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm8668')
-rw-r--r--target/linux/adm8668/Makefile2
-rw-r--r--target/linux/adm8668/config-3.34
2 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
index 8ad2e71eae..4e49332b6f 100644
--- a/target/linux/adm8668/Makefile
+++ b/target/linux/adm8668/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=adm8668
BOARDNAME:=Infineon WildPass ADM8668
-FEATURES:=squashfs
+FEATURES:=squashfs usb pci
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
LINUX_VERSION:=3.3.8
diff --git a/target/linux/adm8668/config-3.3 b/target/linux/adm8668/config-3.3
index b365db19ad..169245d1cc 100644
--- a/target/linux/adm8668/config-3.3
+++ b/target/linux/adm8668/config-3.3
@@ -94,5 +94,9 @@ CONFIG_TULIP_NAPI=y
# CONFIG_TULIP_PCI is not set
CONFIG_TULIP_PLATFORM=y
# CONFIG_ULI526X is not set
+CONFIG_USB_ARCH_HAS_XHCI=y
+# CONFIG_USB_HCD_BCMA is not set
+# CONFIG_USB_HCD_SSB is not set
+CONFIG_USB_SUPPORT=y
# CONFIG_WINBOND_840 is not set
CONFIG_ZONE_DMA_FLAG=0