aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-01-27 21:50:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-01-27 21:50:00 +0000
commite68d03ea41fb83a5eb9846121ed26a6096d3b378 (patch)
tree14575818b79c90ad573db07f42e56885017971b3 /target/linux/adm8668/image/Makefile
parent2e7adc9de9e1743416eb51e4770aab3692080cc4 (diff)
downloadmaster-187ad058-e68d03ea41fb83a5eb9846121ed26a6096d3b378.tar.gz
master-187ad058-e68d03ea41fb83a5eb9846121ed26a6096d3b378.tar.bz2
master-187ad058-e68d03ea41fb83a5eb9846121ed26a6096d3b378.zip
[adm8668] fix firstboot with new MTD map driver
my-mkimage previously did not include the fs_mark of deadc0de because upon formatting of jffs2 partition, U-Boot's CRC validation would not allow the image to boot. This new MTD map will shrink the kernel+rootfs+fs_mark image and recalculate the CRC, so that only the kernel is part of the image validation. This also improves boot time, since less is copied from FLASH->RAM. This is mostly from brcm47xx, just with u-boot image vs TRX partitions. Signed-off-by: Scott Nicholas <scott.nicholas@scottn.us> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25176 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm8668/image/Makefile')
-rw-r--r--target/linux/adm8668/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/adm8668/image/Makefile b/target/linux/adm8668/image/Makefile
index e9d183b789..57b8d7ba54 100644
--- a/target/linux/adm8668/image/Makefile
+++ b/target/linux/adm8668/image/Makefile
@@ -16,11 +16,14 @@ define Image/Prepare
$(MAKE) -C lzma-loader \
KDIR="$(KDIR)" \
clean compile
+ rm -f $(KDIR)/fs_mark
+ touch $(KDIR)/fs_mark
+ $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
define Image/Build
./my-mkimage $(KDIR)/loader.bin $(KDIR)/root.squashfs \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1).bin
+ $(KDIR)/fs_mark $(BIN_DIR)/$(IMG_PREFIX)-$(1).bin
endef
$(eval $(call BuildImage))