aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
commitb5bb9272ee773d30c1fde2da17c087618264ab6f (patch)
tree682cca857e1946d5a258823cfa55f3c40d9daa64 /target/linux/adm5120
parentb5f4a9f364263f9f1fdc5093b00b223154aaf5fc (diff)
downloadmaster-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.gz
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.bz2
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120')
-rw-r--r--target/linux/adm5120/image/router_le.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/adm5120/image/router_le.mk b/target/linux/adm5120/image/router_le.mk
index 6df6dcd8cc..1e3d7f7226 100644
--- a/target/linux/adm5120/image/router_le.mk
+++ b/target/linux/adm5120/image/router_le.mk
@@ -72,7 +72,7 @@ define Image/Build/Cellvision
$(call Image/Build/Loader,$(2),bin,0x80500000,0x6D8,y,$(3))
mkdir -p $(BIN_DIR)/tmp
cp $(KDIR)/loader-$(2).bin $(BIN_DIR)/tmp/vmlinux.bin
- gzip -9 $(BIN_DIR)/tmp/vmlinux.bin
+ gzip -9n $(BIN_DIR)/tmp/vmlinux.bin
dd if=$(BIN_DIR)/tmp/vmlinux.bin.gz of=$(call imgname,$(1),$(2))-xmodem.bin bs=64k conv=sync
rm -rf $(BIN_DIR)/tmp
$(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))