aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/router_le/profiles/Edimax.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-05 14:50:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-05 14:50:53 +0000
commit9d47349f5e464d9e73cf6dbbe90c2fdefd830521 (patch)
treeaac39509a89a3de8ac29fbf671629f7c1d2c9990 /target/linux/adm5120/router_le/profiles/Edimax.mk
parent30b9dbe50f6f147241f840a7ae235a59ca95656b (diff)
downloadmaster-187ad058-9d47349f5e464d9e73cf6dbbe90c2fdefd830521.tar.gz
master-187ad058-9d47349f5e464d9e73cf6dbbe90c2fdefd830521.tar.bz2
master-187ad058-9d47349f5e464d9e73cf6dbbe90c2fdefd830521.zip
[adm5120] Edimax BR-6104K/KP specific fixes
* add profile for Edimax BR-6104KP which contains the experimental USB driver by default * generate CSYS style images which are uploadable via ADMBoot/TFTPBoot (saves 64KB of space) * update kernel configuration git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9141 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/router_le/profiles/Edimax.mk')
-rw-r--r--target/linux/adm5120/router_le/profiles/Edimax.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/adm5120/router_le/profiles/Edimax.mk b/target/linux/adm5120/router_le/profiles/Edimax.mk
new file mode 100644
index 0000000000..34798b2381
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/Edimax.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BR6104KP
+ NAME:=Edimax BR-6104KP
+ PACKAGES:=kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/BR6104KP/Description
+ Package set optimized for the Edimax BR-6104KP
+endef
+
+$(eval $(call Profile,BR6104KP))