aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches/006-adm5120_leds.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-02-09 10:29:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-02-09 10:29:28 +0000
commit1fd898c4d2c67f89b150c212fcd439728ca97508 (patch)
tree4f218ef0f6446459af163261d140df7165ab2ba8 /target/linux/adm5120/patches/006-adm5120_leds.patch
parentb734512859db60d7344c6546e2a3eff2b1dbbdd0 (diff)
downloadmaster-187ad058-1fd898c4d2c67f89b150c212fcd439728ca97508.tar.gz
master-187ad058-1fd898c4d2c67f89b150c212fcd439728ca97508.tar.bz2
master-187ad058-1fd898c4d2c67f89b150c212fcd439728ca97508.zip
[adm5120] switch to 2.6.24
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10427 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches/006-adm5120_leds.patch')
-rw-r--r--target/linux/adm5120/patches/006-adm5120_leds.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches/006-adm5120_leds.patch b/target/linux/adm5120/patches/006-adm5120_leds.patch
new file mode 100644
index 0000000000..a055b3560f
--- /dev/null
+++ b/target/linux/adm5120/patches/006-adm5120_leds.patch
@@ -0,0 +1,38 @@
+Index: linux-2.6.24/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.24.orig/drivers/leds/Kconfig
++++ linux-2.6.24/drivers/leds/Kconfig
+@@ -18,6 +18,21 @@ config LEDS_CLASS
+
+ comment "LED drivers"
+
++config LEDS_ADM5120
++ tristate "LED Support for ADM5120 GPIO LEDs"
++ depends on LEDS_GPIO && MIPS_ADM5120
++ help
++ This option enables support for LEDs connected to GPIO lines
++ on ADM5120 SoC based platforms.
++
++config LEDS_ADM5120_EXPERIMENTAL
++ bool "Enable ADM5120 LEDs experimental code"
++ depends on LEDS_ADM5120
++
++config LEDS_ADM5120_DIAG
++ bool "Enable ADM5120 LEDs diagnostic mode"
++ depends on LEDS_ADM5120
++
+ config LEDS_CORGI
+ tristate "LED Support for the Sharp SL-C7x0 series"
+ depends on LEDS_CLASS && PXA_SHARP_C7xx
+Index: linux-2.6.24/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.24.orig/drivers/leds/Makefile
++++ linux-2.6.24/drivers/leds/Makefile
+@@ -5,6 +5,7 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
+ obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
+
+ # LED Platform Drivers
++obj-$(CONFIG_LEDS_ADM5120) += leds-adm5120.o
+ obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
+ obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
+ obj-$(CONFIG_LEDS_SPITZ) += leds-spitz.o