aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.3/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
commite1a582c1ce36074d9e481afe66c88a8c7d7a8376 (patch)
tree2a4d205fd4cde0b74a467cf30081e0ab4c627ba9 /target/linux/adm5120/patches-3.3/103-mtd_trxsplit.patch
parent0965fa8af6cd23a5871b3b12053a97c559f97d18 (diff)
downloadmaster-187ad058-e1a582c1ce36074d9e481afe66c88a8c7d7a8376.tar.gz
master-187ad058-e1a582c1ce36074d9e481afe66c88a8c7d7a8376.tar.bz2
master-187ad058-e1a582c1ce36074d9e481afe66c88a8c7d7a8376.zip
adm5120: add 3.3 support
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31474 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-3.3/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-3.3/103-mtd_trxsplit.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.3/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-3.3/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..421dcaa628
--- /dev/null
+++ b/target/linux/adm5120/patches-3.3/103-mtd_trxsplit.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -31,6 +31,10 @@ config MTD_ROOTFS_SPLIT
+ bool "Automatically split 'rootfs' partition for squashfs"
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ ---help---
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o