aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.3/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-25 12:57:33 +0000
commite1a582c1ce36074d9e481afe66c88a8c7d7a8376 (patch)
tree2a4d205fd4cde0b74a467cf30081e0ab4c627ba9 /target/linux/adm5120/patches-3.3/007-adm5120_pci.patch
parent0965fa8af6cd23a5871b3b12053a97c559f97d18 (diff)
downloadmaster-187ad058-e1a582c1ce36074d9e481afe66c88a8c7d7a8376.tar.gz
master-187ad058-e1a582c1ce36074d9e481afe66c88a8c7d7a8376.tar.bz2
master-187ad058-e1a582c1ce36074d9e481afe66c88a8c7d7a8376.zip
adm5120: add 3.3 support
Partially based on the 3.1 patches by Hartmut Knaack <knaack.h [at] gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31474 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-3.3/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-3.3/007-adm5120_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.3/007-adm5120_pci.patch b/target/linux/adm5120/patches-3.3/007-adm5120_pci.patch
new file mode 100644
index 0000000000..e757bb50b2
--- /dev/null
+++ b/target/linux/adm5120/patches-3.3/007-adm5120_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o
+ ops-bcm63xx.o
+ obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
+ obj-$(CONFIG_SOC_AR724X) += pci-ath724x.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+
+ #
+ # These are still pretty much in the old state, watch, go blind.
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1803,6 +1803,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000