aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 18:10:04 +0000
commit1f07007293c2a98abd721bf6bbe112c5cae71525 (patch)
tree24e08ec57941d3a93d99d153f86458ae7e026f69 /target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
parent57a3eb31a2a14cd25099c0e1e3569b2c75a9e38e (diff)
downloadmaster-187ad058-1f07007293c2a98abd721bf6bbe112c5cae71525.tar.gz
master-187ad058-1f07007293c2a98abd721bf6bbe112c5cae71525.tar.bz2
master-187ad058-1f07007293c2a98abd721bf6bbe112c5cae71525.zip
adm5120: add experimental 3.14 kernel support
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43915 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..698b66908c
--- /dev/null
+++ b/target/linux/adm5120/patches-3.14/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -490,4 +490,12 @@ config LEDS_BLINKM
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -63,3 +63,4 @@ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o