aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/image/lzma-loader/src/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-12-14 20:35:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-12-14 20:35:22 +0000
commit6e108a99a0f7a6a18d6d7296cdb9baed76167f8e (patch)
tree97ee76e406f8d46978e2ea2bd89fb250552e5bfd /target/linux/adm5120/image/lzma-loader/src/Makefile
parent00c20e169e732d196c0ec117ab2a552796d6bc0d (diff)
downloadmaster-187ad058-6e108a99a0f7a6a18d6d7296cdb9baed76167f8e.tar.gz
master-187ad058-6e108a99a0f7a6a18d6d7296cdb9baed76167f8e.tar.bz2
master-187ad058-6e108a99a0f7a6a18d6d7296cdb9baed76167f8e.zip
[adm5120] update LZMA code
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9756 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/image/lzma-loader/src/Makefile')
-rw-r--r--target/linux/adm5120/image/lzma-loader/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/adm5120/image/lzma-loader/src/Makefile b/target/linux/adm5120/image/lzma-loader/src/Makefile
index a553b7fdef..aad845ae07 100644
--- a/target/linux/adm5120/image/lzma-loader/src/Makefile
+++ b/target/linux/adm5120/image/lzma-loader/src/Makefile
@@ -40,7 +40,7 @@ CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-ffunction-sections -pipe -mlong-calls -fno-common \
-ffreestanding \
-mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
-CFLAGS += -DLOADADDR=$(LOADADDR)
+CFLAGS += -DLOADADDR=$(LOADADDR) -D_LZMA_PROB32
ASFLAGS = $(CFLAGS) -D__ASSEMBLY__ -DLZMA_STARTUP_ORG=$(LZMA_STARTUP_ORG)