aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commit6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e (patch)
tree30cacdb892969714d2a079f391ba6786b7c36489 /target/linux/adm5120/Makefile
parent9647361f814667b536160d416666bd25ab4b82fa (diff)
downloadmaster-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.gz
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.bz2
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8694 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/Makefile')
-rw-r--r--target/linux/adm5120/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index f8436c04ed..34c3b804a7 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -1,27 +1,20 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
include $(TOPDIR)/rules.mk
-ARCH:=mipsel
BOARD:=adm5120
-BOARDNAME:=ADM5120 (Little Endian)
-FEATURES:=squashfs jffs2 tgz broken
-
LINUX_VERSION:=2.6.22.4
+FEATURES:=squashfs jffs2 tgz broken
-define Target/Description
- Build firmware images for Infineon/ADMtek ADM5120 based boards
- (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
-endef
+include $(INCLUDE_DIR)/target.mk
-include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += admswconfig
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call Target,router_be))
+$(eval $(call Target,router_le))
+$(eval $(call BuildTarget))