aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
commit1c4a2a55f76e481a2d1bc005405b9ce856d58939 (patch)
tree80dfa6ecb493ee8cb9ca1436f1b37ee89f320a55 /target/linux/Makefile
parentfdd5681c06468a606180f04c2533c8ba213a37f6 (diff)
downloadmaster-187ad058-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.gz
master-187ad058-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.bz2
master-187ad058-1c4a2a55f76e481a2d1bc005405b9ce856d58939.zip
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/Makefile')
-rw-r--r--target/linux/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/Makefile b/target/linux/Makefile
new file mode 100644
index 0000000000..ced6dca005
--- /dev/null
+++ b/target/linux/Makefile
@@ -0,0 +1,33 @@
+include $(TOPDIR)/rules.mk
+
+define kernel_template
+
+$(1)/$(2)-clean:
+ $(MAKE) -C $(1) BOARD="$(2)" clean
+
+$(1)/$(2)-prepare:
+ $(MAKE) -C $(1) BOARD="$(2)" prepare
+
+$(1)/$(2)-compile:
+ $(MAKE) -C $(1) BOARD="$(2)" compile
+
+$(1)/$(2)-install:
+ $(MAKE) -C $(1) BOARD="$(2)" install
+
+ifeq ($(BR2_LINUX_$(3)),y)
+clean: $(1)/$(2)-clean
+prepare: $(1)/$(2)-prepare
+compile: $(1)/$(2)-compile
+install: $(1)/$(2)-install
+endif
+
+.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-install
+endef
+
+prepare:
+compile:
+install:
+clean:
+ rm -rf $(BUILD_DIR)/kernel
+
+$(eval $(call kernel_template,linux-2.4,brcm,2_4_BRCM))