aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-12-02 12:20:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-12-02 12:20:43 +0000
commitf63d024ee2e48783fac3d276d75e31c60f56bdb8 (patch)
tree4163325b843d7a74cdafa9dc66fe3f78e7b888cd /target/imagebuilder
parent6acaf2e4703f43b7336ed75c49a5b03867cd724b (diff)
downloadmaster-187ad058-f63d024ee2e48783fac3d276d75e31c60f56bdb8.tar.gz
master-187ad058-f63d024ee2e48783fac3d276d75e31c60f56bdb8.tar.bz2
master-187ad058-f63d024ee2e48783fac3d276d75e31c60f56bdb8.zip
imagebuilder: use file_copy to deploy files/ in the image generation phase
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34439 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile10
1 files changed, 1 insertions, 9 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 4d0f1fe115..ecaf5ccda3 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -134,15 +134,7 @@ package_install: FORCE
copy_files: FORCE
@echo
@echo Copying extra files
- @( cd $(USER_FILES); find -type f ) | \
- ( cd $(TARGET_DIR); while :; do \
- read FILE; \
- [ -z "$$FILE" ] && break; \
- [ -L "$$FILE" ] || continue; \
- echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
- rm -f "$$FILE"; \
- done; )
- $(CP) $(USER_FILES)/* $(TARGET_DIR)/
+ @$(call file_copy,$(USER_FILES)/*,$(TARGET_DIR)/)
package_postinst: FORCE
@echo