aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 09:47:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 09:47:37 +0000
commitace825551c2dc07a621149451f987a1baf92b9da (patch)
tree7eac3005729b61c286fe41e2a4f158e83f40ba06 /target/imagebuilder
parent99b93333557037a9177d1a4c60df2d67ad2126e5 (diff)
downloadmaster-187ad058-ace825551c2dc07a621149451f987a1baf92b9da.tar.gz
master-187ad058-ace825551c2dc07a621149451f987a1baf92b9da.tar.bz2
master-187ad058-ace825551c2dc07a621149451f987a1baf92b9da.zip
feeds: use common macro "FeedSourcesAppend" to populate opkg configurations
This introduces a common macro to assemble the correct url templates to avoid code duplication and have the feed config handling in a central place. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45799 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 218def7e1d..7f48ed885f 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -37,20 +37,10 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
ifeq ($(CONFIG_IB_STANDALONE),)
echo '## Remote package repositories' >> $(PKG_BUILD_DIR)/repositories.conf
- ifeq ($(CONFIG_PER_FEED_REPO),)
- echo "src/gz %n %U" >> $(PKG_BUILD_DIR)/repositories.conf
- else
- for d in base $(FEEDS_ENABLED); do \
- echo "src/gz %n_$$d %U/$$d" >> $(PKG_BUILD_DIR)/repositories.conf; \
- done
- ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
- for d in $(FEEDS_DISABLED); do \
- echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$$d %U/$$d" >> $(PKG_BUILD_DIR)/repositories.conf; \
- done
- endif
- endif
+ $(call FeedSourcesAppend,$(PKG_BUILD_DIR)/repositories.conf)
endif
+ echo '' >> $(PKG_BUILD_DIR)/repositories.conf
echo '## This is the local package repository, do not remove!' >> $(PKG_BUILD_DIR)/repositories.conf
echo 'src imagebuilder file:packages' >> $(PKG_BUILD_DIR)/repositories.conf