aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-16 11:56:19 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-16 11:56:19 +0000
commita0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9 (patch)
tree5b8926dfc465868bbff96e7e131d2e4122bff9c9 /target/imagebuilder
parent420eec3ba8ff272511d476381734a65335999510 (diff)
downloadmaster-187ad058-a0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9.tar.gz
master-187ad058-a0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9.tar.bz2
master-187ad058-a0bbe0d6ce12fd8ca7d60061ed6756c247fc45d9.zip
postinst trigger: the new postinst trigger broke IB
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42571 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 72a91e0740..8136111b67 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -54,6 +54,7 @@ help: FORCE
# override variables from rules.mk
PACKAGE_DIR:=$(TOPDIR)/packages
OPKG:= \
+ IPKG_NO_SCRIPT=1 \
IPKG_TMP="$(TOPDIR)/tmp/ipkgtmp" \
IPKG_INSTROOT="$(TARGET_DIR)" \
IPKG_CONF_DIR="$(TOPDIR)/tmp" \
@@ -142,12 +143,12 @@ package_postinst: FORCE
@rm -f $(TARGET_DIR)/tmp/opkg.lock
@echo
@echo Activating init scripts
+ @mkdir -p $(TARGET_DIR)/etc/rc.d
@( \
cd $(TARGET_DIR); \
- for script in ./etc/init.d/*; do \
- grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
- IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
- done || true; \
+ for script in ./usr/lib/opkg/info/*.postinst; do \
+ IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) $$script; \
+ done || true \
)
rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst
$(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)