aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-09-14 16:57:03 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-09-14 16:57:03 +0000
commit8fe050e1f8a432f1fe93a1875a0652465ac642e0 (patch)
tree0d121b95be04324ab17abb7fd8734a4ada16e0a6 /target/imagebuilder
parent400f242858a16bdecd4679f9e5325770448d7f64 (diff)
downloadmaster-187ad058-8fe050e1f8a432f1fe93a1875a0652465ac642e0.tar.gz
master-187ad058-8fe050e1f8a432f1fe93a1875a0652465ac642e0.tar.bz2
master-187ad058-8fe050e1f8a432f1fe93a1875a0652465ac642e0.zip
imagebuilder: store package lists in cache directory
Force opkg to store the downloaded repository indizes into the cache directory as well, this way the IB can be used in an offline setting once all required files have been cached. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46912 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 479fa0e850..f612ea9abc 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -53,6 +53,7 @@ help: FORCE
# override variables from rules.mk
PACKAGE_DIR:=$(TOPDIR)/packages
+LISTS_DIR:=$(subst $(space),/,$(patsubst %,..,$(subst /,$(space),$(TARGET_DIR))))$(DL_DIR)
OPKG:= \
IPKG_NO_SCRIPT=1 \
IPKG_TMP="$(TMP_DIR)/ipkgtmp" \
@@ -65,6 +66,7 @@ OPKG:= \
--force-overwrite \
--force-postinstall \
--cache $(DL_DIR) \
+ --lists-dir $(LISTS_DIR) \
--offline-root $(TARGET_DIR) \
--add-dest root:/ \
--add-arch all:100 \